分享一下Django + Celery + redis做任务队列可用的版本配置

标签: 疑难杂症  Django

小白用Django + Celery + redis做任务队列注意事项

起因

最近又用Celery做任务队列,又遇到了版本不兼容导致的各种异常,经过一番调试后,终于成功。同时也发现,很多文章和帖子都是讲怎么在Django中使用redis和celery,没有讲到注意事项,初学者往往按着教程学习时各种报错,备受打击。所以,我在此记录下一套可用的版本号配置。

可用配置

celeryredis的版本非常重要

Django==2.1
celery==3.1.25
django-celery==3.3.1
django-redis==4.11.0
redis==2.10.6

强烈建议初学者建议按此版本安装,少走弯路

正常启动的效果

正常

常见报错

目前celery和redis的版本都已经升级得比较高了,如果安装时不指定低版本的话,就会出现报错,下面两种是我在安装过程中遇到的报错情况

redis版本太高(3.0以上)

reids


Celery版本太高(4.0以上)

在这里插入图片描述

原文链接:加载失败,请重新获取