ubuntu12.04安装ruby2.3

原文链接:http://www.cnblogs.com/dspace/p/6103008.html

为了搭建github-pages博客,而github-pages后端依赖于ruby,且对版本有严格要求,自己尝试了各种姿势升级ruby2.3无果,最终在查阅了各种资料之后找到一个可行方案。

[email protected]:~$ sudo apt-get -y install software-properties-common 
[email protected]:~$ sudo apt-add-repository ppa:brightbox/ruby-ng 
[email protected]:~$ sudo apt-get update
[email protected]:~$ sudo apt-get -y install ruby2.3

同时不要忘记了安装ruby2.3的开发库,不然还是会遇到各种坑.....

[email protected]:~$ sudo apt-get install ruby2.3-dev

升级ruby到2.3之后执行

bundler update

还是出现以下错误
706914-20161125213232675-1040685398.png

奇怪的是竟然不影响github-pages的安装

[email protected]:~$ sudo gem install github-pages

运行jekyll server

[email protected]:~$ bundle exec jekyll serve

设定jekyll server监听IP,这个跟Flask和Django差不多,直接在后面加上--host参数就OK

[email protected]:~$ bundle exec jekyll server --host=0.0.0.0

默认会监听4000端口

转载于:https://www.cnblogs.com/dspace/p/6103008.html

原文链接:加载失败,请重新获取